Degraded Performance

Incident Report for Huntress

Resolved

This incident has been resolved.
Posted Jan 22, 2025 - 22:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 22, 2025 - 19:37 UTC

Investigating

We are currently investigating this issue.
Posted Jan 22, 2025 - 18:46 UTC
This incident affected: Incident Reports and MDR for Microsoft 365.