Portal Degradation

Incident Report for Huntress

Resolved

This incident has been resolved.
Posted 11 months ago. May 23, 2024 - 21:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 11 months ago. May 23, 2024 - 20:00 UTC

Investigating

We are currently investigating this issue.
Posted 11 months ago. May 23, 2024 - 19:15 UTC