Huntress Portal down
Incident Report for Huntress
Resolved
This incident has been resolved.
Posted Sep 22, 2022 - 14:42 UTC
Monitoring
The dashboard is back online and we are monitoring performance
Posted Sep 22, 2022 - 14:07 UTC
Investigating
We are currently investigating this issue.
Posted Sep 22, 2022 - 13:55 UTC
This incident affected: Management Portal (huntress.io).