ITDR Onboarding Failures

Incident Report for Huntress

Resolved

This incident has been resolved.
Posted Aug 01, 2025 - 18:11 UTC

Monitoring

After working with the upstream provider, a fix has been rolled out and onboarding appears to be working as expected.
Posted Aug 01, 2025 - 12:30 UTC

Identified

Onboarding is degraded due to a problem with the upstream provider. We are actively escalating the problem through multiple channels.
Posted Aug 01, 2025 - 00:30 UTC

Investigating

We are currently investigating this issue.
Posted Jul 31, 2025 - 22:42 UTC