Degraded Performance
Incident Report for Huntress
Resolved
This incident has been resolved.
Posted May 17, 2022 - 16:51 UTC
Identified
We've identified a backend issue that may cause timeouts or latency for some users. Once this is resolved we will post an updated status.
Posted May 17, 2022 - 13:23 UTC
This incident affected: Management Portal (huntress.io).