ITDR Ingestion Delay

Incident Report for Huntress

Monitoring

We're continuing to work with our partners at Microsoft, who have identified the cause of the delay and are in the process of implementing a fix. We are still seeing intermittent delays of up to 4 hours for some customers.

We will continue to provide updates as soon as more information becomes available.
Posted Sep 01, 2026 - 22:09 UTC

Identified

We've identified that the cause of our ingestion delay is from a degradation in Microsoft's M365 APIs.

No GWS customer are affected.

We're working through our partner channels to get this resolved, and will update this page as soon as we know more information.
Posted Aug 31, 2026 - 17:37 UTC

Investigating

We have noticed a slight delay in our ITDR ingestion pipeline, and are investigating the cause.
Posted Aug 31, 2026 - 16:53 UTC
This incident affects: ITDR.